Mouse bug

Why isn’t this a default? I have a terribly slow HDD in my laptop and was wondering why it lags so much. I’m going to enable it right now on my PC. Thanks.

3 Likes

That option is HUGE for laptops, especially when trying to save battery life.
The only way to play the game smooth without micro stutters on laptop on battery, at least for me, was to use maximum performance, which would drain the battery very fast. The weird thing is that even when I set the processor to less than 40% the game was smooth on AC, but horrible on battery.

But with that option activated, everything changes. Just waiting 2 more secs for the game to start, the stutter is gone, even when playing on ultra power saving mode, on 20% battery. There are some occasional frame drops, but it is very much playable.

2 Likes

And you don’t need to have HDD powered up all the time since the files are already in the RAM. This NEEDS to be a default thing.

EDIT:
It could be loaded while connecting to the servers and probably no one would notice. This way you still have super fast boot (in my case it was literally 2 seconds of loading so not a problem) and you can just use the time that is needed to log onto the servers, because you can’t get rid of it.

1 Like

These days, unfortunately, people seem to have an issue with anything that so much as resembles a load time.

I agree that, if that load time is the only reason not to disable DelayedLoad, then it should be default.

That said, my laptop isn’t exactly a spring chicken and I haven’t had any issues with CIU before - probably because I also have plenty of free space though.

That would probably only be possible if it’s a unique CIU feature and not a feature of the underlying engine, unless the API makes provision for it. As someone with coding experience I would be surprised if that would work, unfortunately (but I’m not the one coding the game so I don’t actually know so I need to stop talking).

image

I think you’ll benefit from bEnableDelayedLoad=No

Also, your disk usage is pinned at 100%. This is very suspicious and will slow your system down a lot. Is it always like this? Select “Open Resource Monitor” at the bottom. Select the “disk” tab and see if you can identify why your disk is being used so much (sort by “Total B/sec”)

Starting with v.35, bEnableDelayedLoad is replaced with a new “load mode” that has 3 settings:

  • Immediate: Everything loads at start-up (same as bEnableDelayedLoad=false)
  • On-demand: Everything loads when needed (same as bEnableDelayedLoad=true)
  • Opportunistic (default): Things will load slowly in the background over the first 10-20 seconds. There will be slight stuttering during this stage, but it should eventually cease. This DOES require enough memory to fit everything in at the same time (same as Immediate mode), so there might be problems on low-end systems. We’ll see.
4 Likes

Yeah well. I would call it bottom-end if you’re not able to get 350MB of RAM for one app.
Raspberry Pi 4B is more powerful than my laptop that I used for 10 years. And it costs 55$

1 Like

The disk usage is always 100% when I turn on my laptop

If you leave it on for 10 minutes, does it go down from 100%? 100% is only reasonable if the system has just booted up.

@qbus371: 350MB is the on-disk size. In-memory size is currently 580MB (due to expansions of .JPGs and monochrome textures)

1 Like

Well, that’s weird. I had it at exactly 350MB when I was testing it.

:man_shrugging:

At the main menu:

image

When connected to server:

image

Now it is getting interesting.

Are you sure that bEnableDelayedLoad=No in your system? I’m talking about the memory utilization when everything is loaded at startup.

2020-03-12_16-29-30
Yes. This time however it was loading at the start for 7 seconds instead of 2.

And your memory utilization at the main menu is …? (don’t connect to the server)


EDIT: Sorry, Firefox got highlighted.

Well, WTF. :thinking:

3 Likes

I enabled it back on. And now I’m concerned.
Menu:


In mission:

Maybe we can create new topic and collect more data from other players if it helps anyhow. I’m now super confused.

1 Like

It does go down from 100% and then it rises up again and continues

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.