Can't select difficulty as of late in Steam versions of CI3, CI4, and CI5

Hello. This is a bug that’s started appearing recently for me on the Steam versions of CI3, CI4, and CI5. When I want to start a new game, the difficulty selection is set to “Beginner” by default, but when I try to click on “Veteran” the check-mark moves to “Veteran” for a very short period of time before it automatically moves back to “Beginner”. Sometimes you don’t even notice the check-mark moving. The same thing happens when you try to customize your ship in CI5. You just can’t change the default selection in the UI.

I tried testing this on my Windows 10 lap top, on Linux Mint 20 on the same lap top, and on Windows 11 on my friend’s PC, and everywhere it’s the same. So I assume it has something to do with Steam?

I first installed CI4 around November 4th, I think. I didn’t have these issues then. An hour later I went to a friend’s place, logged into my Steam account, installed CI4 there and started the game, when the bug started appearing. A couple of days later I tried CI4 on my lap top where the issue started showing itself too. Ever since then I wasn’t able to avoid this bug no matter what I did. I tried some weird Steam console hacks where you download older versions of the game and its files, but to no avail.

At first I thought it was some Windows update that messed it up, but when the exact same behavior started reproducing itself on Linux I assumed it has something to do with Steam or one of the libraries it uses, then. Or one of the game’s libraries if it uses dynamically linked libraries.

1 Like

It’s most likely a problem with the game itself. I don’t think it’s a steam problem. The best thing you can do is to report the bugs and wait for an answer.

If you go to Options → Controls → Joystick/Gamepad → Player 1 Controls, are any joysticks listed there? Click on the “Joystick” field and see if any of the 4 entries show anything.

4 Likes

None of the fields show anything (-- is shown).

Huh. What if you use the keyboard (use the arrow keys to navigate, and ENTER to select). Can you get the selection to “stick” this way?

5 Likes

I tried that before, the behavior is exactly the same as if I clicked with the mouse.

Just tested this on another PC I haven’t tested before, and the behavior remains. I guess this should be easily reproducible for anyone who has the Steam version of the games.

I think this problem is most likely linked to your particular Steam account. Perhaps there is a setting somewhere (related to controller remapping? or perhaps Steam Play?) that interferes. Go to Steam → Settings and check all tabs (try disabling In-Game → Enable the Steam Overlay, and also disabling Remote Play → Enable Remote Play. Also Controller → General Controller Settings)

In any case, I don’t think it’s a generalized problem. Lots of people in this forum use Steam and have the games, so they would have complained about such a game-breaking issue.

3 Likes