[SOLVED] CIU fails to start on Linux

I dont know I’m even supposed to post this here, but anyways:
CIU fails to launch on linux (steam).
It gives this error, does anyone know a fix? What does this error mean?
It used to work fine on my previous linux os (Ubuntu 23 something)
image
Current OS:
Debian 12 Stable

1 Like

does linux have directx graphic driver or something?

1 Like

The error message seems to relate to DirectX. While sadly I can’t help much with your issue, what I can tell you is if you want to run the game on Linux, I recommend doing so using Steam’s Proton.

1 Like

No it doesn’t. But there are translation layers like WINE. (just like emulator but not an emulator)

He already uses it. There’s no linux native CIU on Steam so to even launch it you must use Proton.

I’d normally point to the GPU not supporting Vulkan, but you said that it worked in Ubuntu 23. It’s older base than Debian 12, but it still should be similar.

Still. What GPU do you use right now? Which Proton version have you tried? Which Desktop Environment do you use?

1 Like

Most of users use windows i literally dont know about linux

please learn, for your safety from some companies
proton experimental

1 Like

I ve never used linux

I’d still bet on the gpu.

Try older proton version - right now you’re probably using v9. Try v7 or v6 as they use older Vulkan.

Your gpu does support Vulkan so there should be no need, but you can also try using the OpenGL instead:
“PROTON_USE_WINED3D=1 %command%”

Who cares. Then don’t reply in the topic about linux troubleshooting.

2 Likes

Ok😒

I’ve just tried this out myself, also Debian 12 Stable, I am using Proton Experimental. Before that I’ve also used standalone version through PortProton but I don’t remember doing anything specific for it to run on either RX560 and (nowadays) RX6750 GRE. I doubt that was helpful anyhow, my linux experience is very limited.


UPD: Actually I dug up something in CID:


That supposedly began to happen at 06.06.23 after some Steam update.

↑ this thing is apparently fixed nowadays, by the way. I’ve just successfully switched to full screen and it worked.

This worked!
As you said, my gpu does have vulkan support,

Screenshot of Vulkaninfo

image

trying opengl worked smh, maybe something is wrong with my steam installation, i get this error while launching steam:


I tried but I cannot find any solution to it :confused: . Something is wrong with the i386 libs

2 Likes

Sadly I won’t be able to help more.
You may also try installing the Flatpak version of Steam, but bear in mind that it takes more space, it’s not official and some games are not compatible with that version. (mostly VRs)

Also, for future, you don’t need to edit the topic to add solved. There should be option to mark some post as an solution.

Not here for some reason, that’s why.

IA probably forgot to enable it for “CIU development” category. Well, not a big deal.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.