Problem When launching the game

I was opening ciu after i downloaded update i clicked on the game to see it but it kicked me i tried a second try but it worked but why does that happens?

which version were you tried to open?

New Version (136500)

On android?


I have only the android

You must use version 1360501, because 0500 is having a bug which will crash upon startup.

How can i download the 1360501 version then

You can of course check this topic to download. If you have 32 bit android OS, use the external link below Google Play to download and install it manually.

I have 64-bit

Update your game on Google Play Store. Done.

I updated it fully but it keeps says 1360500

And if i downloaded apk should i keep my google play version?

There’s already an update of the game on Google Play. Check it again.

Ok ima check it tonight and tell you because i will be busy,goodbye.

Hey Bro The Game Updated Itself And The Version Became 1360501 Thank You Bro And This Crash Is No Longer Happens Thank You So Much

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.