Local multiplayer doesn't seem to work

Hey everyone,

So it’s been quite some time since I’ve last written here. Maybe even years.
Even though i haven’t been playing every single day with the game, it just always felt good to return after some weeks or months to see what’s new, and I’m really glad to see that the game is finally out of early-access state.
So recently I started playing actively again, and also convinced my brother to download the came so that we can play in co-op. Unfortunatly, things didn’t exactly go as planned… I can connect to almost anyone, and the game also shows that we are on the same network, but I just can’t get past the “estabilishing route” sign. I’m not really familiar with this kind of stuff, so all I could try is turning off my and my brother’s firewall, and I also tried to create a port forwarding on my wi-fi, but I’m still not able to join. I’ve tried it with a vpn, and I was able to join with that, but because of the high latency (300-360ms) the game is kind of unplayable for me. Does anyone know how should I possibly fix this? Is it just for me or it’s a game-related issue? Thank you for reading.

This is not the first report about LAN games issues so I guess this is a bit more complex than “the problem at your end”. In any case, try this:

this can be due to your router settings
log in your router by typing, you can find the password on one side of your router
normally it can be username: admin and password: admin
in conclusion this can be due to wireless isolation as iA stated above

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.