Bug Report - Graphics Problem


#1

Dear Interactions,
While trying your newest beta, I used a 4K screen, and also a weird old 1680x1050 one*…
By default, my computer uses my smaller screen to run programs and games, and everything worked out just fine, as expected.
When I switched to the 4K screen, the game’s resolution was set to the same properties as it was with the smaller one.
But that isn’t my point. (Altho it would be nice if the game will recognize the resolution automatically… just saying)

You see, the moment I switched to 4K resolution, the framerate dropped down to like 8fps, (and I think I saw some blinkings too),
and the biggest issue was that the mouse couldn’t pass the 2560x2048 pixel, as can be seen in the following screenshot:

I believe that you will find the solution quickly and easily,
Thank you for your time,
Roei Meiri

*BTW
I used this very screen to run CI3 the first time… What an amazing masterpiece you’ve got there…
Specifically from a musically and gameplay point of view. Well Done Guys!


#2

Hmm… how did you “switch to the 4K screen”? How can you choose which screen is used for games?

Also, please send us (either here or e-mail support@interactionstudios.com) the game log:

C:\ProgramData\InterAction studios\CIU\6\CIU.log


#3

To switch, I used the well-known shortcut “start+p” and then I chose “PC screen only”.
To make the programs run through the smaller screen, I opened up Settings, then I chose “Display” and then “Make this my main display”

Now before I send you the game log (which I must say it would be very interesting to see), I should say firstly that after I retried to change to 4K resolution, everything worked out fine. Also, I should say that for my second try I switched first to 2560x2048 resolution, and then to 4K, what makes me believe that the problem has something to do with the jump between 1680 x 1050 to 4K resolution specifically, or between different size ratio…

https://drive.google.com/file/d/1EsgqMWcIawB6nnD75QtE51XsByK5iSo6/view?usp=sharing


#4

The log shows the selected resolution as 1680x1050, there’s nothing about 4K.

Can you please re-run the game, make whatever series of changes to the resolution you need until your mouse can no longer move over the entire screen, then immediately press Alt+F4 to quit the game and send us the log.


#5

This is the list of events and thoughts I had until I gave up.

  • 16:10: Unfortunately, the bug no longer happens, I will try to reinstall it and hope to the best… (By by progression…)
  • 16:30: I don’t find any more clues of CIU being installed on my computer (nothing at the registry key, program data, program files…). Maybe we’re going to have a fresh installment of the game and we’ll find the mysterious bug?
  • 16:31: No bug for me… I remember I chose to reset the tutorial before changing the resolution… maybe it will help?
  • 16:32: Nope.

Conclusion: I think that there is something, maybe with the registry key, that I should remove to make the bug happening again.