Android version compatibality


#1

After full release you said we have the mobile versions too. What will be the minimum android version to install the game? I have android 4.2.2 jelly bean and 2gb ram, can I install it?


#2

you probably will be able to run it if you can download and play the other Chicken invaders games


#4

I can run another versions on my phone like CI5 and CI4. But they may change the android version compatibility.


#5

The intention is to keep Android compatibility the same as in previous episodes.


#6

I could play CI4 on Sony Erricson Xperia X8 with custom android 2.3, it was playable