(About movement in galaxy and interupted trip) Bug or working as intended?


#1

@InterAction_studios

  • First, i want to go to the red star system(middle of image), but i think i will lose a lot of fuel if i start at Hecate or Gyges (because of using offroad). So my plan was: start at Hecate, use instellation highway to Gyges (for cheaper cost), during the transit i will stop at the middle(using interupted trip button, already bought it before), then use offroad to go to that red star system.
  • But after using interupted trip, i can’t go to this star system because game say i am already there! (And i can’t explore any planet in that star system):
  • Now if i want to go back to Hecate, i MUST use offroad (I think it should use instellation highway):
  • For other star system, i still can use offroad:
  • Yep, my plan fail miserably(even worse, i lose twice or even thrice the amount of fuel than expected lol) . Hope IA or anyone can explain why the game said to me i am already there. Bug? or working as intended? Thanks alot!
    (I think maybe my ship is IN the range of that red star system).

#2

I think you cheezed it and the game didn’t know what to do. Will probably need to make this somehow impossible (You can’t travel to a system from a middle of a highway) or just fix that it says you are already there.


#3

I agree with the fix. But about the “make this somehow impossible”, they will need to remove interrupted trip button and item, and this will be a alot harder for IA, i guess.


#4

Yeah. When I first saw it I thought it just took you back, like on a rubber band


#5

Hmmm… the problem is that the RNG created the Titan system (the red one) too close to the interstellar highway. Normally, there shouldn’t be any overlap between systems and highways.

But your fuel-saving plan was valid and it would have indeed worked if you had interrupted your trip even just a little bit outside Titan. But you stopped inside it (normally impossible with non-overlapping highways and systems, but possible in this case), and that confused the game.


#6

Carnus system on Adikia constellation is also too close to an interstellar highway. Didn’t find other star system with this problem, there are some close to interstellar highways, like Kyrbas on Hypnos, but no overlap. I wonder if travelling off-road and interrupting inside a star system may result in this problem too, but i can’t test it.


#7

The same problem would occur for all overlaps.

Ok, fixed for the next update. If you now interrupt a warp trip over an unexplored star system, the star system gets automatically explored.

Also, props for the overall fuel-saving plan. :+1:


#8

It’s nice to hear that. What about the go back to started star system if we stop in the middle? I think it should use instellation highway instead of offroad.


#9

That’s not possible. Everyone knows that there aren’t any on-ramps to interstellar highways in the middle of nowhere :stuck_out_tongue:


#10

@InterAction_studios Actually, i just tried that:


From Gyges, i went to Hecate (using instellation highway), i interrupted in the middle, now i can go back to Gyges using instellation highway. (Dunno why i couldn’t use this trick in the situation beginning of this topic).


#11

When you try to travel via an interstellar highway but you’re outside of any star system, your autopilot first takes you to the nearest star system and takes the highway from here. But you can’t just join in a highway half-way between star systems.

The reason you couldn’t use this before is that your nearest system was unexplored (and unexplored systems cannot be used for highway travel).


#12

I’ve found that interrupting a trip juſt outſide of the deſtination reſults in getting ſtuck- you’re not in nor out of the deſtination ſtar ſyſtem.


#13

Hm… I think the fix below will also cover your case.