Ship stuck

So, today I tried to play a wave and the ship got to top of the screen shooting like crazy, and there’s nothing I can do about it. If I click, it apears on the bottom and quickly gets to the top again, Alt+X didn’t work so I had to quit with alt+F4. Anyone else had this problem?

Restarting the game does nothing, and as soon as I load my account I’m in the wave again, on top of the screen shooting. Pause doesn’t work neither, absolutly nothing responds except for Alt+F4. Right mouse click works. Toogling Capture Mouse doesn’t anything neither.

When you hold down the right click button, ſome letters in brackets might ſhow up at the lower-right corner (e.g. [Space][D]). Do they? Which letters are they?

No, nothing at all. The only thing that happens is my satellites shooting.

I assume the game worked properly for you in the past? Is this a new installation, or a new computer?

Try this first:

Turn off Options -> Controls -> Mouse -> Capture mouse.

If this doesn’t work, try this:

Go to Options -> Controls -> Joypad -> Customize Joypad. Select all possible options (1 to 4) under “Joypad”. Do they all say “–”? Or is one of them different than the others?

@Traveller: The right-click debug feature was removed in v.28

2 Likes

Okay, I’ve never this embarassed in my whole life. Your guiding led me to find the source of my problems. Mainly because I said ‘yeah, I don’t have a joystick’. Then I realised that I do have a joystick and I looked down to unplug it and I found this:


So yeah, I’m a complete idiot and I don’t deserve to have a computer. :laughing:
On a side note, it’s strange that the joystick movement doesn’t let you even pause the game with Esc key.

Thank you and I’m very sorry for your lost time. I’m also very embarassed.

2 Likes

:joy:

The reason the ESC key isn’t working is that the game internally maps joypad movement to virtual keys, and only one pressed key (the very first one you pressed) is ever checked. So ESC is being overridden by the “joypad up” key.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.