Satellite weapons

Seems the latest update 27, now has the satellite weapons firing when you fire main weapon. Anyone else have this problem?

Have you turned off Satellite auto fire? You can toggle it by going into options and then gameplay


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.