Lots of problems


#1

I juſt fired up the game with the intention of killing ſome chickens. I found a miſſion that looked fun, and preſſed play, at which point all hell broke looſe. You ſee, I ſtarted ſpamming the fire button earliër than uſuäl, i.e. as ſoon as the miſſion ſtarted (I was rather enthuſiäſtic, as you might have gathered), and that’s when thing ſtarted to go all pear-ſhaped. My ſatellites fired in ſync with the forks, which they are not ſet to do, and what’s more the barbequers continued to fire (they were firing continuöuſly deſpite the fact that I was firing ſingle ſhots) even after I ſtopped ſhooting my forks. They kept on firing until they ran out of fuël, at which point they vaniſhed as they are ſuppoſed to. By this point I’d diſcovered that the eſc key waſn’t pauſing the game, ſo I alt + tabbed away. As an experiment I went back and the game immediätely reſumed without diſplaying the pauſe ſcreen.

Pre-poſting poſtſcript: I juſt alt-tabbed back to it, and it’s now pauſed.

I’m not planning to go back to the game juſt now, in caſe you want me to try ſomething.


#2

What keys (or mouse buttons) do you use to fire (a) your weapons and (b) your satellites?


#3

I ſteer with my mouſe and ſhoot with my keyboard.
Primary fire: ſpacebar (although mapped to a carriage return character with my keyboard layout)
Satellites: C (although ſometimes I uſe my mouſe- right click, but I waſn’t preſſing either here)
Special weapons: X


#4

Ok, made a small change in the next update that might help. Will probably also need to add a debug mode especially for this – more info nearer that time.


#5

From the new update:

Temporary debug feature: holding the right mouse button down during a mission will display currently pressed keys at the bottom-right of the screen.

Next time your keyboard misbehaves or the ESC key isn’t working, hold down the right mouse button and make a note of ALL keys that appear at the bottom-right of the screen and post them here.


#6

A question? Why when the red asteroids appear i have some frame problem or idk. The game slows a little bit and go back to normal.


#7

That’s probably the smokey trails they leave behind. They require a DirectX 9.0 feature (D3DTA_TFACTOR) that is very poorly emulated on some modern GPUs.

CI5-style large explosions share the same problem :cry:


#8

Red asteroids make the game some lagging


#9

Well… Maybe after making CIU it should be time to work on new engine using Vulkan or DX11 API? (don’t use DX12 - it’s exclusive W10 APi that Microsoft made to attract users to their newest OS)


#10

I think no. Because Chicken Invaders is lightweight game for every device.


#11

How about different size for PC? Hmmm?


#12

High quality for only PC ?


#13

If you are saying it has to lightwieght, why not? Why should the PC be locked because phones can’t handle that? It’s not unfair to the phones or anything, right?


#14

Maybe you’re right.


#15

Maybe Universe will get new powerfull 3d engine if it get popular in few years… I wish.


#16

@InterAction_studios, I juſt had a problem where I tried to pauſe the game uſing the eſc key, but it didn’t work. I then preſſed the right mouſe button and tried, and there was the eſc key liſted, but alſo the F3 key. It was in the order [Eſc] [F3], if this helps.


#17

Did you ever use the F3 in the game? Or another key mapped to the F3 key?


#18

Well, on my laptop Fn + F3 is for volume control, ſo I might have releaſed the Fn before the F3 key or ſomething like that. I did adjuſt the volume when I ſtarted the game.


#19

I juſt had the game pauſed, thought I’d juſt play around with this a bit, and managed to reproduce the problem. It has to do with the rollover of my keyboard, I think. I’ve gotten ſtuck keys by preſſing certain combinations, for example E-R-W-Q-T in that order it’ll liſt only [Q][W][E][R]. If I releaſe the middle three keys ſimultaneöuſly, it’ll liſt the Q and the T but alſo continue to liſt ſome of the middle keys. This blocks the Esc key from working, and I think is alſo the cauſe of the ſatellite malfunction. I’m not that hopeful that you’ll be able to fix this, though, as it appears to be hardware/operating ſyſtem related; if I Alt + Tab away and back, the ſame keys are ſtuck down. They unſtick when I preſs them again.


#20

I couldn’t replicate this on my keyboard (all 5 keys are detected; if I press more they won’t register until I let some of the previous ones go, but in both cases they are all removed once I stop pressing them).

I suspect that the cause of this may be that key-remapping utility you use.