🌎 How to translate the game

Give the medal to Madder, he is the one who had issues with highlighted text, trying to understand why it is not yellow.

2 Likes

Best news I’ve read.:fire:

1 Like

Who?

5 Likes

Madder, that’s his in-game callsign. He is in CID only.

Ok, done.

7 Likes

I’ve also created a separate post about official translators here: 🌎 Official translators wanted

Questions/discussion about that should be posted here.

9 Likes

i seem to have found a few bugs currently present in the translation menu:

  • on the “Recently seen (all)” menu, if one makes a translation for a string that wasn’t previously translated, scrolls to another page, then scrolls back, the newly translated string will have the “Approve existing translation” button next to it as if it was created by another player. This doesn’t appear to happen with any of the other menus, although I haven’t tested it for the Related menu
  • when opening the translation menu during a mission, upon closing it the player ship gets teleported to wherever the cursor was upon closing the menu, potentially causing a lost life
  • highlighting text seems to be buggy, and often doesn’t work at all, though I’ve been unable to figure out any patterns to when it works and when it doesn’t or how to cause the bug
2 Likes

It is possible that you have not included the exact amount of |, $ and ^ characters in that phrase. See if there is any error below the translated phrase’s field after clicking on it, and follow its instructions.

Known. Pause the mission beforehand.

Also known:

1 Like

The last time that happened to me it was a formatting error, I put an incorrect amount of the pipe | characters. Check your lines for this.

Pretty sure this was a known thing. There is also that annoying issue that “capture mouse” doesn’t let you move the mouse all the way down to the bottom field. It’s still clickable, however.

Do you have the high contrast mode enabled?

5 Likes

I don’t know how I was missing that all that time and I could not find whether it was reported because “the search item is too short”, but apparently you can’t translate kg and km.

изображение

oh yeah, that might be it, tried doing it again and it only happens on strings with $ and | characters

i think i remember it happening with the regular pause menu at some point in the past too, don’t think i’ve seen it reported for the translation menu as well though. it’s not on the known bugs list at least, but i haven’t looked through all of the replies in this thread

i don’t, but by highlighting i meant highlighting text with your cursor to copy-and-paste it between different strings, not bolding it for ingame appearance - i guess the bug could just be on my end though since i haven’t found any ways to cause it

Oh, so selection is broken. I thought that was my mouse acting up, because it’s a bit broken and I could not select a part of some line in the past.

1 Like

oh alright, that confirms it’s not just on my end then. how or why is still unknown though - for me sometimes it works just fine and sometimes it doesn’t work at all

@InterAction_studios Is it possible that main translators have a special logo like CHL?

Is the fact that you are displayed in the credits not enough?

11 Likes

It was just an idea… But I agree with you.

Fixed in v.140.3

Fixed in v.140.3

Ensure that the field has focus first – selection won’t work otherwise.

8 Likes

it still seems like it occasionally breaks - upon starting the game selection works fine, but at some point it stops working and doesn’t fix itself until I restart the game
I haven’t gotten any screen recordings of it, but I did get this screenshot from last time it happened


after this point, I was unable to select again until a restart. this was on the beta version (been using that so I can test CI3U and CI5U translations, exporting them once finished), but I’ve had the issue on the stable version too, this instance happened while translating while playing through CI5U, and I’m playing through Proton (perhaps that’s the cause? I’ll see if I can get the same issue running the game natively on Windows)

1 Like

okay, did some more testing and I think I figured out what’s going on - selection breaks if the player opens the translation menu in the middle of a mission, without pausing it beforehand. It resumes functioning if the player closes it, pauses the mission, then reopens it, but it always breaks if opened during an unpaused mission. Tested it and it happens across both Windows and Linux, and tried on two different computers and it happens on both, so def not a bug on my end or Proton-related

1 Like

Ugh. Acknowledged, but it strangely only happens in the release build of the game, but not the debug. This is going to be a pain to fix – on the list. As a workaround, pause the game first whenever you need to copy-paste.

6 Likes