Game crashes on startup via Steam

This is a specific issue for me, but every other steam game I’ve opened has been fine, and the original web installation of CIU worked just fine for me (though my account isn’t connected to that one at the moment.) When I attempt to open the game through Steam or the Steam Library directly, a small window opens up, the fullscreen game opens, and then closes less than half of a second afterwards. No error, just a crash and nothing else.

A friend of mine along with myself did figure out the likely culprit to be related to a new graphics card, but I’m not actually sure why this causes the game to crash. The new card is an NVIDIA GeForce RTX 2060, and my old one was something close to an AMD 390. I did swap the graphics drivers when putting the new card into my computer, so I know that’s not the problem either. I’m just confused.

Windows 10 Pro, x64 bit, Intel(R) i7-5820K CPU

Not experienced with hardware issues, especially Nvidia and Intel related, but you can check the crash log in C:/ProgramData/InterAction studios/CIU/steam/105. Maybe it will show what exactly is going wrong. Note that ProgramData folder is hidden by default.

A bit unexperienced with crash logs - I’m not too sure what I’m looking for in it, exactly. It seems like it’s telling me a normal boot log and is just checking my computer first. I did notice a weird tiny bit where it seems to think I have no drivers related to audio - I lack speakers on my Monitor or Desktop in any way, and just use a USB headset for audio.

Scroll to the end of the file and look what happened before the engine started shutting down. It should be around 5-15 lines from the bottom.

Try updating your drivers

Well are you sure that swapping drives is the last change you did before the game starting to crash bec it have a low possibility to have the card be the problem try upgrading you driver or reinstalling steam also check steam crash reports
Some problems may happen via steam itself

Started.
Change request from 1 to 3 (t=0.241).
Changing mode from {1} to {2}.
Applying presentation.
About to SetWindowPos (0,0) 1920x1080 IsIconic=0
GetWindowPlacement: flags=0x0 showCmd=0x1 ptMinPosition=(-1,-1) ptMaxPosition=(-1,-1) rcNormalPosition=(0,0)-(1920,1080)
Creating DirectX device…
Device feature level: 11.0 (index 0)
Creating DirectX window-specific resources…
New swap chain.

^ These are the things on bottom. There’s not actually anything indicating a crash or error at all. I’ve attempted to open it again it light of this, and that adds up. It almost doesn’t even seem like the game is actually running before it even shuts off.

Sorry for not responding sooner, that was the first day of my account and I got hit with the reply limit. To also add to it a bit more, my friend (sup Desogran) gave me the possibility that it might have something to do with DirectX or needing to reinstall it. I attempted that, but it told me I already had a newer or equivalent version, and I couldn’t find a newer one on Microsoft’s page, so that isn’t a problem either, unless I’m somehow just screwed in that regard as well.

1 Like

Probably another swap chain issue. Something related to them has happened before. The only thing I can do is ping @InterAction_studios in a hope they see this.

Although it could be a DirectX issue, as @VerMishelb explained, I find it very weird that the stand-alone works, but Steam does not (because all DirectX stuff is common between the two). Did you actually try the stand-alone version recently (with your new graphics card)? Download v.105 to make sure it still works: ⬇ Download Early Access

Also, in the same folder where you found the .log file, there should also be a minidump file (it ends in .mdmp). Send it to me in a personal message here, or in an e-mail to support@interactionstudios.com and I’ll look into it.

3 Likes

I’ll stick with the E-Mail, since for some reason I can’t seem to DM people on this forum. I’ve been told it should just be a choice after clicking a users’ avatar, but it just doesn’t seem to be there for me. I’m not sure if that’s down to my account being very recent, but alongside that I am seemingly restricted to a single reply per day.

You can expect to see that file and my other input as soon as I can test v.105 to see if it works properly. Thank you, by the way.

3 Likes

That’s the cause of the problem. The only solution is wait

2 Likes

(Copying this here for future reference:)

Thanks for supplying your crash dump. It appears that the crash happens inside “gameoverlayrenderer.dll” (this is Steam’s overlay, it doesn’t belong to the game itself).

Go to your Steam Library, right-click on the game, select “Properties”. In the “General” tab, UNCHECK “Enable the Steam overlay while in game” and try launching the game again.

This is not a permanent fix (because without the Steam overlay you won’t be able to purchase anything inside the game), but please report whether this works for you and we’ll take it from there.

5 Likes

Update: Disabling the Steam overlay did not work.

Try this:

Go to your Steam Library, right-click on the game, select “Properties”. In the “General” tab, in the field “Launch options”, type in:

-safe

Make sure to include the dash in front of “safe”

2 Likes

Update: Adding “-safe” did not help either.

4 Likes

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.